druid、mybatis plus发生SQLFeatureNotSupportedException的兼容性问题

GoogleVip8 2月前 ⋅ 214 阅读

最近新项目使用mybatisplus和druid,发现报错了,网上找原因原来是durid兼容问题,之前用druid1.1.10一直都正常,现在使用mybatisplus3.2就出了这个问题,解决这个问题网上也有很多方案,我说一下以下几种解决方法。

第一种:使用最新版的druid 1.1.21 https://github.com/alibaba/druid/releases

第二种: 降级 mybatisplus 小于3.2

第三种: 将java8的Local Data Time 改为Date

关于新版druid的监控问题:

之前使用老版本不需要太多配置就可以在监控了,新的版本种不配置监控就是空数据,网上找了个配置: https://segmentfault.com/a/1190000019718506?utm_source=tag-newest 我试了可以解决,当然了,想要了解更清楚的配置可以看官网。

写在最后:好久没有更新文章了,最近忙项目,遇到问题记录一下啊,喜欢我的文章记得关注我哦


全部评论: 0

    我有话说: